Free certificate issuance with degraded performance

Incident Report for bunny.net

Resolved

As per Lets Encrypt status page, this has been resolved - we similarly have observed no degradation/failures on certificate renewals since their update went out.
Posted Jun 19, 2026 - 09:37 UTC

Identified

We identified that this is due to an issue currently experienced by the Let's Encrypt service. Existing certificates on custom domains will continue to function as normal - however new and cert renewals via our free certificate option may experience errors to the certificate issuance. You can follow https://letsencrypt.status.io/ for more details.
Posted Jun 18, 2026 - 20:58 UTC

Investigating

We have identified an issue with free certificate issuance and renewals for custom CDN domains.
Posted Jun 18, 2026 - 20:57 UTC
This incident affected: API and CDN.