Increased Response Times for Statistics Reporting

Incident Report for bunny.net

Update

Our Engineering team has identified the issue of the statistics response delays, and are preparing a fix
Posted Mar 30, 2026 - 15:29 UTC

Identified

We are working on an issue with our Statistics API endpoint. There are increased response times probing CDN and DNS statistics, resulting in some delayed reports, or timeouts. This affects both dashboard and direct API requests for statistics.
Posted Mar 30, 2026 - 09:05 UTC
This incident affects: Dashboard and API.