DNS issues with bunny.net

Incident Report for bunny.net

Resolved

An internal process failure related to the management of our bunny.net domain with one of our domain registrars led to the temporary suspension of the domain, causing multiple services under bunny.net to become unavailable.

After identifying and confirming the issue, we worked with the registrar to restore the domain and all affected services are now recovering as DNS changes propagate globally. We have identified the root cause internally and are implementing additional safeguards and escalation procedures to ensure this cannot happen again.

During the outage, products and services under bunny.net experienced varying levels of disruption depending on DNS propagation and their dependency on bunny.net infrastructure and Bunny DNS.

Services including the Website, Dashboard, API, DNS, and related tools experienced widespread availability issues. Other products such as Stream and Magic Containers saw limited disruption and remained largely operational for most users, though some functionality was impacted depending on DNS resolution and service dependencies. Core services such as CDN delivery and Storage remained operational throughout the incident.

We will publish a full public RCA once the incident is fully resolved, including additional details around the timeline, service impact, root cause, and the preventative measures being implemented.

We're deeply sorry for the disruption and inconvenience caused. We expect the situation to fully resolve over the next few hours as DNS propagation completes worldwide. If you have any questions, please contact support@bunny.net.
Posted May 21, 2026 - 18:21 UTC

Monitoring

A fix has been implemented and all impacted services have recovered. We're monitoring.
Posted May 21, 2026 - 16:51 UTC

Identified

We've identified an issue with the configuration of one of our primary domains, bunny.net, impacting most of our services. We're working to fix it.
Posted May 21, 2026 - 16:39 UTC
This incident affected: Website, Dashboard, API, CDN, DNS, Edge Storage, Optimizer, Origin Shield, Bunny Fonts, Edge Scripting, Magic Containers, Bunny Shield, Bunny Database, CDN Logging and Stream (Stream Service, Stream - Transcoding Service).