Isolated 502s for Magic Containers and Edge Scripting

Incident Report for bunny.net

Update

We have made some routing adjustments to mitigate the timeouts on Database and is fully operational again. Our Engineering team is continuing to investigate the Magic Containers issue.
Posted Apr 30, 2026 - 12:16 UTC

Update

We are continuing to investigate this issue.
Posted Apr 30, 2026 - 10:14 UTC

Investigating

We are currently looking into isolated 502s within the NA region for CDN endpoints utilizing Magic Containers and Edge Scripting. This is primarily affecting specific regions in North America.

Our Engineering team are investigating the issue currently.
Posted Apr 30, 2026 - 10:12 UTC
This incident affects: Magic Containers and Bunny Database.