CDN configuration sync delays

Incident Report for bunny.net

Resolved

The fix has been deployed to all nodes. We will be readding the missing nodes to the pool today.
Posted May 27, 2026 - 11:15 UTC

Monitoring

A fix is being staged on a subset of affected nodes. Impacted nodes are since identifying the issue isolated from CDN traffic and only receiving test traffic. Further updates will be provided after testing concludes and deployment to all affected nodes is complete.
Posted May 26, 2026 - 16:00 UTC

Identified

We've been observing 25 to 30 nodes in various PoPs around the world exhibiting constant delays with syncing their configuration since yesterday evening. We've depooled all impacted nodes as a temporary workaround and working on a permanent fix.
Posted May 26, 2026 - 06:47 UTC
This incident affected: CDN.