Increased response times for CACHE MISS

Incident Report for bunny.net

Resolved

We have now deployed a global fix and cache MISS latency has normalized.
Posted Jun 14, 2025 - 09:47 UTC

Identified

We've identified an issue causing increased response time for a small percentage of origin pull requests (cache MISS pulls). This is causing increased delivery times for these requests. We have located the issue and a fix is being deployed.
Posted Jun 10, 2025 - 16:37 UTC
This incident affected: CDN.